How to compile FFmpeg on Ubuntu and Debian

Editions: Light, Community, Professional, Enterprise, Ultimate, Corporate
Versions: all

The FFmpeg packages in Ubuntu and Debian 5 "Lenny" don´t support transcoding to all HTML5 formats.

This tutorial describes how to compile FFmpeg.

This HowTo has been tested with Ubuntu 12.04 LTS, 13.04.

In this tutorial we assume that you´re in /usr/src (cd /usr/src) and the Multimedia Repository is added as source.

If you installed FFmpeg and x264 before, remove them first:

apt-get remove ffmpeg x264
apt-get autoremove

1. We start with installing some packages:

apt-get update
apt-get upgrade
apt-get install make automake g++ bzip2 python unzip patch subversion ruby build-essential git-core checkinstall yasm texi2html libfaac-dev libmp3lame-dev libopencore-amrnb-dev libopencore-amrwb-dev libsdl1.2-dev libtheora-dev libvdpau-dev libvorbis-dev libvpx-dev libx11-dev libxfixes-dev libxvidcore-dev zlib1g-dev

2. We install yasm

wget http://www.tortall.net/projects/yasm/releases/yasm-1.2.0.tar.gz
tar xvzf yasm-1.2.0.tar.gz
cd yasm-1.2.0
./configure
make && make install
cd ..

3. We install x264:

git clone git://git.videolan.org/x264.git
cd x264
./configure --enable-shared
make && make install
cd ..

4. We install libvpx

wget http://webm.googlecode.com/files/libvpx-v1.1.0.tar.bz2
tar xvjf libvpx-v1.1.0.tar.bz2
cd libvpx-v1.1.0
./configure 
make
make install
cd ..

5. We check the paths for ldconfig

Open /etc/ld.so.conf and check, if the paths /usr/lib and /usr/local/lib exist in the file. If not, add them.

Then execute ldconfig:

# ldconfig

6. We install FFmpeg

wget http://ffmpeg.org/releases/ffmpeg-0.8.10.tar.bz2
tar xvjf ffmpeg-0.8.10.tar.bz2
cd ffmpeg-0.8.10
./configure --enable-gpl --enable-version3 --enable-nonfree --enable-postproc \
--enable-libfaac --enable-libmp3lame --enable-libopencore-amrnb \
--enable-libopencore-amrwb --enable-libtheora --enable-libvorbis \
--enable-libvpx --enable-libx264 --enable-libxvid
 make
 make install
cd ..

7. IMPORTANT: execute ldconfig

ldconfig

FFmpeg is now installed at /usr/local/bin/ffmpeg. Insert this path for FFmpeg in ViMP´s backend at administration -> configuration -> transcoder.

8. Last but not least, copy the presets to /usr/local/share/ffmpeg and eventually you have to install qt-faststart as well: Presets und faststart

8.10

Last update on 2017/05/15 by Admin.

Go back