Everything new at ViMP

Simultaneously with ViMP 4.0 we launched our new website!

We have done our best to make the website as clear and user-friendly as possible.

Your feedback is very much appreciated! Please let us know what you like and what we can improve.
 

Your feedback

 
Thank you and have fun on our new website and with ViMP 4.0!

Sincerly, Your ViMP team

Feedback
 

ViMP System Requirements

  • You need a dedicated or virtual server with root permissions to install ViMP.
  • We recommend Linux as OS. An installation under UNIX, BSD or Windows is possible, but not officially supported.
  • We recommend to not use Plesk due to possible incompatibilities.
     

The following server software is required to run ViMP

Apache2
  • Version 2.2 or 2.4 recommended
  • mod_rewrite must be enabled
PHP
  • Version 5.5.x, 5.6.x, 7.0.x
  • GD library, Mcrypt, cURL, MySQL, mbstring, MySQLi, PDO, pdo_mysql and XSL extensions must be installed
  • PHP CLI (Command Line Interface) must be installed
MySQL/MariaDB
  • MySQL: At least version 5.0
  • MariaDB: At least version 10.0
  • InnoDB must be installed
Transcoding
The transcoding tools should be installed exactly as described in the documentation. Due to patent protections it's not sufficient to install the default packages.
  • FFmpeg
  • additional codecs
     

Hardware

Our minimum recommendation is as follows:
  • Quad Core Processor or better
  • 8 GB RAM (better 16 GB or more)
  • 500 GB hard disc space (the actual capacity needed depends on the number of media)
For additional data security, we recommend using a RAID controller.